Blog Basics

Presented by Polly-Alida Farrington
PA Farrington Associates
polly@pafa.net

2007
What are Blogs?

A blog or web log, is a web site with a series of postings with news, updates on a project, personal diary entries or similar content. The newest entries are generally presented first. Web logs have been around since the early ‘web’ days. The ‘What’s New’ list from the folks who created the Mosaic browser can be considered one of the earliest blogs.

Why are they so popular now? Free and easy! Tools that make it easy and free (or cheap) to create your own blog have driven the popularity. There’s no need to have a web site host, a domain name or any knowledge of HTML. With very little effort you can be sharing your most profound (or not!) thoughts with the world.

There are millions of web blogs covering any topic you can imagine. Topics include politics and social issues, news analysis, personal blogs and professional news.

Blogging from a conference has become a popular way to provide conference news to those who couldn’t attend. Blogs can be used as newsletters and if you allow others to comment on your postings, they can become interactive communities. Some organizations have set up their whole web sites around blogs, since they offer an easy way for people to update sections of a web site.

Terms

- **Posts** – Each entry is called a post. Shown in reverse chronological order.
- **Archives** – Older posts are stored in archives files. Only the most recent posts are displayed on the main page.
- **Comments** – Many blogs allow readers to leave comments. You can read them from the comments link. Use the comments link to and add your own comments to the discussion.
- **Permalink** – The URL for the permanent location of a posting. As new entries are posted, the ones on the main page will get bumped down the list and will land in the archives. To link to a post from another web page or email, use the ‘permalink’.
- **Trackbacks** – This feature lists other blogs that have links to a posting. Handy to find out what others are saying about an entry.
- **Categories** – Set up your own list of categories to match the topics you cover in your blog. Each posting in the blog can be assigned to one or more categories. This makes it easy for users to find all the postings on a particular topic. Used for organizing links to external web sites as well.
- **Plugins** – 3rd party features that you can add to your blog to show additional content. The calendar on the SALS blog is a plugin.
- **Themes** – Layout and design of your site. Most blogging software provides a selection of themes. Some systems let advanced users can create their own themes with CSS.
- Static Pages – Pages that remain the same for an extended period of time. They are edited individually and don’t contain blog postings. Handy for including information about an organization, links to popular resources, policies and such.

Library Blogs

Why blog in a library? Newsletters, teen pages, new books, online book discussion, events….. anything that needs to be updated frequently. Pages that become more interesting because they’re updated often will bring more users to your site. Users can ‘subscribe’ to your pages with their ‘feed readers’, getting the latest library news in a timely manner and without having to remember to go to the library page.

Blogs also provide an opportunity for community feedback. The commenting features on most blogs allow readers to leave comments on your posts and ask questions. You can respond to comments by leaving a comment as well. Commenting can be moderated by the blog owner – inappropriate and spam comments can be kept out of your blog.

DIRECTORIES
If you create a blog for your library, submit it to the various blog directories. (see list on class page at http://lib20.pbwiki.com

Blog Directories and Search Engines

Directories help you find blogs, search engines find individual postings within the blogs. Check out the blog search tools listed on the class resource page at http://lib20.pbwiki.com
Get Blogging with WordPress

Blogs have been set up for you on the SALS blog server and details will be provided to you in class.

Jot down the specifics for YOUR blog.

**BLOG URL (address) ____________________________

USERNAME ____________________________

PASSWORD ____________________________

**VIEW YOUR BLOG**

- Take a first look at your blog
- The basic blog has a title and a tag line under the title. These can be changed in your administration Dashboard.
- There’s also a sample posting and comment.
- The right sidebar has some default content. You’ll be able to add your own content from the administration Dashboard.

**Login and Start Posting**

- Click on the Site Admin or Login link at the lower right side of your blog.
- Enter your username and password.
- This takes you to the Dashboard page. The Dashboard has all of the administration options for your blog. It’s also the place where you’ll write all of your blog posts.

- On the Dashboard click on the WRITE tab at top or the Write a Post link a little further down the main Dashboard page. Both take you to the same screen.
WRITING POSTS

- Enter a **Title** for your first post/entry.
- Type the text of your post in the larger of the boxes.
- You can use text formatting by selecting text and clicking on the formatting icons.
- The editing toolbar has options for **bold**, **italicizing**, **strikethrough**, **bulleted lists**, **numbered lists**, **indent**, **outdent**, **alignments**, **linking and unlinking**, **inserting an image**, **inserting a 'read more' link**, **spellchecker** and help.
- Tabs above the box switch between Visual editing and HTML Code view editing.

CATEGORIES

- Categories help your readers find posts that are of interest to them.
- Use the **Categories** section on the right to start adding topics that you plan to cover in your blog.
- Enter a topic for this entry and click on **Add**. The category will be added to the list.
- Add a few more categories. If one doesn’t apply to this posting, unclick the box in front of it.
- If you don’t want your post listed in the **Uncategorized** category, uncheck that box as well.
- Users reading your blog will have the option to browse through your blog by these categories, Very handy as your blog grows.
- Finish writing your first post. As you write, you can click on the **Save and Continue Editing** box to save your work. A handy feature.
- When your entry is done, click on the **Publish** button.

**Note:** Some people prefer writing their posts in Notepad, WordPad or some other editing program and then copy the text to WordPress. Don’t copy and paste directly from MS Word though, it creates too much extra code. The latest version of MS Word does have a blogging feature built.  You can also blog directly from flickr. Pretty handy if you’re inserting a photo.

READ MORE LINK

- A good way to squeeze lots of posts on your main page without it getting overly long is to use the **“read more”** option.
- Start a new post and write a few sentences to introduce your topic. Then use the **Split** icon on the editing toolbar to add a **Read More** link.
- Continue typing the rest of your post after the **more** symbol.
EDITING POSTS

- Click on Manage → Posts
- This retrieves a list of all posts. Each has a View, Edit and Delete option.
- Select the option you need. Remember to Publish the post when you’ve finished editing.

Adding Images

On the Posting screens there is an option to UPLOAD photos to your blog server. These images can then be placed in your post. WordPress will automatically set the size of the image to be a small thumbnail size to go in your post. You have the option to link that thumbnail to the original size version of the image.

WARNINGS!!

- Don’t upload your original photos from your camera. They’ll probably be HUGE! Digital cameras can easily take images that are over 2,000 pixels wide these days – and bigger. Monitors are usually 800 -1200 pixels wide. Those images would fill the whole screen and then some.
- Make sure you resize your photos in a graphics program before you upload them. Images take up a lot of memory and big images can take forever to load. And even if the photo appears to be thumbnail size on the screen, it’s really not! It’s the same big image squished into a smaller space through the magic of HTML. Picnik.com is a great, free, online photo editor. Or upload your images to flickr.com, flickr automatically creates several resized versions of your photo.

UPLOADING AN IMAGE

- Start a new post: Write → Write Post
- Below the Post editing box, look for the Upload and Browse All tabs.
- Click on the Upload tab, then on the Browse button at the end of the File box
- Find an image on your computer to upload. Select the picture and click on the Open button in the dialog box.
- When you get back to the editing screen, the image filename should be in the File box.
- Add a text title for the image. This helps make your images ‘visible’ to people reading your page with a screen reader or with the images turned off.
- Click on the Upload box on the bottom right.
- Your image is now in the Browse panel.
ADDING AN IMAGE TO YOUR POST
- Click on the Browse tab.
- Click on the image you want to add to your post.
- Select the full size option and link to file options.
- Click on Send to Editor
- If the photo is too big, resize it and upload it again.
- Publish your post and see how it looks in the blog.

Adding Links to your Posts
- In your post, select the words that you want to use as a hotlink.
- Click on the little link icon in the editing toolbar
- Type the link in the Link URL box.
- Select whether you want that link to open in a new window or in the same window as the blog.
- Add a Title to the link. The title will show up when you hold your mouse over the link for a short time.

Adding Static Pages
Pages are created just like blog posts, but they aren't listed in chronological order. They are listed on the sidebar of your blog. You can create a number of pages and put them in whatever order makes sense to you. These pages can contain any sort of information and are useful for information that doesn't change often, but is often referred to. Library hours, descriptions of library services, library policies – these are the kind of content you might want to add to ‘pages’.

- Use the Write → Write Page option to add a new page.
- Give the page a Title and add some content in the Page Content box.
- Use the Page Order option on the right side of the screen to change the order of the Static Pages.

ADDING YOUR MISSION STATEMENT
Your blog probably has an About page already created. This is a static page like the one you just created. Use it to talk about why you’re blogging, about your library, or …. anything you want to add!
- To get to the page, use the Manage → Pages option.
- Look for the About page and click on Edit
- Add your own content.

HTML CODE
If you’re comfortable with writing HTML, all of the Editing windows have an HTML icon on the editing toolbar. This opens a box with the HTML code for your post. You can edit away if you like!
Embedding Media Content in a Post

It’s fun and informative to have slide shows, videos and other media content included in your blog posts. Some content can be included simply by copying some code and pasting it into your post in the Code editing view.

The basic process:
- **Get some code** from a slide show, video or other media site.
- Go to your **Write → Post** screen
- Click on the Code tab (right above the box where you type your post)
- **Paste the code.**
- Publish!
- Voila

Some examples to try:
- **flickrslidr.com** – Create a slide show from anyone’s flickr photos. If you don’t have a flickr account, use mine (username is pollyalida)
- **youtube.com** – Well this one is just too much fun! Find a video. Copy the “embed” code below the video.
- **Slideshare.net** – find a slideshow that you like. Copy the embed code on the right side of the slideshow. Or put up your own presentation and share it via your blog.

More Administrative Options

**COMMENTS**
The comment feature is very popular in the blog world. Without it your blog isn’t interactive, which is fine if you’re using your blog as a news or announcement service. But if you do wish to turn on the comment feature, you may wish to moderate any comments that are left. This involves reading each comment and approving it before it appears on your blog.

- Use the **Options → Discussion** option to set your commenting options.
- Select the settings you’d like to use for your blog. If you don’t want any comments, **uncheck** the box for Allow people to post comments on the article.
- Additional options allow you to be notified when comments are left and set options for moderation.
- To hold comments for your approval, check the box for An administrator must approve the comment.

**MODERATING COMMENTS**
- Use the **Comments → Awaiting Moderation** option to view comments that are awaiting approval or deletion.
- Comments can be marked for approval, deletion or spam.
DELETING COMMENTS
- Comments can be edited and deleted through the Comments → Comments option.

ADDING OTHER USERS TO YOUR BLOG
- Let others contribute posts to your blog through the Users → Authors and Users option.
- The Add New User option is part way down the screen. Add a nickname, First Name, Last Name, email address and password for them. Web site address isn’t necessary.
- If you want them to share administrative duties, you’ll need to edit their user status after you add them.
  o Contributors can add posts, but can’t actually publish them.
  o Authors can add posts and publish them
  o Editors can add, edit and delete posts – both their own and others.
  o Administrators are the only ones who can change settings and options for the whole blog.

Sidebar Options
When you first set up your blog, you’ll see some basic content in the sidebar. This usually includes a list of the recent posts in your blog, maybe a list of the older posts by month, links to login to administer your blog and so on.

You can customize what appears in the sidebar from the Presentation → Widgets option in your blog’s Dashboard.

As soon as you start rearranging content in the Widgets screen, the default sidebar content is removed. Anything piece removed can be added back to the sidebar and rearranged to suit your needs.

Sidebar widgets also let you display content from other web sites, like flickr photos, LibraryThing book lists, RSS feeds of content from others blogs, latest links added to you del.icio.us account and more.

ADDING BLOGROLL LINKS TO THE SIDEBAR
Links to other websites can appear on the sidebar of your blog. This is often called a blogroll.
You may want to link to other library sites, community sites, book sites, etc. These can appear as a single list of links or broken up into sections or categories. You can name the categories anything you like.

Think of the types of links you want to add and set up some categories. Some likely categories might be Other Libraries, Good Book Sites, Search the Web, etc.

- Use the Blogroll → Add Link option to add your link categories first. (Though you can always add more categories later and reorganize the links as needed.)
- The Add a Category option is on the right side of the screen.
- Type in the name of a new category and click on Add Category.
- The category will appear in a list just below that box.
- Add a few categories, but don’t get too carried away! Your sidebar links should be limited to just a few really useful categories and links. If you want to create lengthy list of links, consider creating a static page full of links.

- When you’ve finished adding categories, add the actual links.
- Click on the Links → Add Links option.
- Enter a Name for the link
- Enter the URL for a link in the Address box.
- A description isn’t necessary, but will show up as a popup note when you roll your mouse over the link.
- Use the Categories check boxes to assign that link to a category.
- The links you add will be listed by category on the side of your blog.
- Links can be edited and deleted from the Blogroll → Manage Blogroll option.

NOTE: If the links don’t automatically appear on the sidebar of your blog, go to the Presentation → Widgets option on your Dashboard and drag the LINKS widget to your sidebar. Save the changes and your links should appear on the blog’s sidebar.

MORE SIDEBAR WIDGETS

Widgets are little bits of content that usually appear on the sidebar of your blog or a web page. The content often comes from other sites or might be content from your own blog.

Some examples:
- Links widget – shows your blog’s lists of links to other websites.
- Posts widget – shows a list of the most recent posts to your blog.
- flickr widget – shows some of your photos
- LibraryThing (LT) widget – displays books in your LT account.
• A meebo widget gives your users a little window to instantly chat with you.

Your WordPress blog software has some handy widget features already built in. You just drop the widget where you want it to appear and tell it where to get the content from. For some services, you’ll need to do some set up on the other websites and copy and paste a bit of code.

**ADD A TEXT WIDGET**

- Go to your blog’s Dashboard.
- Select **Presentation → Widgets**
- You’ll see a box for each sidebar in your blog layout and a section showing the available widgets.
- Look for the **Links** widget in the **Available Widgets** section.
- Drag it up to the sidebar section/box and drop it there.
- Click on **Save Changes**.
- The categories and links you set up earlier will now show up on your sidebar.
- Don’t like where it’s placed? Drag it up or down to change the location.

**MORE WIDGETS**

There are many more widgets available to you. All you need to do is drag ‘em and drop ‘em!

If you want to add content that doesn’t have a widget already set up, try using the **TEXT** widget. You can have up 9 of these, set the number in the Text Widgets option at the bottom of the Widgets screen.

**Example: Set up a flickr Badge with a Text Widget**

- Login to your flickr account.
- Find the **TOOLS** option at the bottom of the screen.
- From there select the **MAKE A BADGE** option
- Follow the steps to set up a badge.
- Copy all the code provided

- Return to your blog’s **Dashboard**
- Select **Presentation → Widgets**
- Drag a **Text Widget** to your sidebar
- Click on the little box icon at the right end of the **Text** box.

- A small window will pop up.
- Paste the flickr code in the bigger box and type a title for your widget in the smaller box.
- Click on the X to close the window.
- Save Changes
- Take a look at your blog to see your changes in effect.
RSS WIDGETS
If the content you want to display is an RSS feed, add an RSS widget. (RSS is a method for taking content from one website and making it appear on another website. If you have a Bloglines account, you've been using RSS!)

Example: Add SALS blog content to your sidebar
- Drag the RSS widget to your sidebar
- Click on the little box icon at the end of the RSS box
- Enter the URL for the SALS blog RSS feed: http://salsblog.sals.edu/index.php/feed/
- Enter a title for this widget. Recent News from SALS might be a good choice!
- Select how many items you want to display.
- Close the popup window and click on the Save Changes
- Headlines from the SALS blog will appear on your sidebar.

You can have up to 9 RSS feeds on the sidebar. RSS content can be found on tons of websites. Just start looking for the RSS links and icons. ( is a common symbol for RSS content.)

Events Calendar
Events listings are regular posts with some special date information added in the Events Editor section of the Write Post screen.

Before you can display events on your blog, you'll need to activate the Events Calendar plugin and the Events Calendar Widget plugin.

Activate Plugins
- Go to Plugins → Plugins
- Activate the Event Calendar plugin
- Activate the Event Calendar Widget plugin

Write a test post and set up an Events Category
- Go to Write → Post
- Add a category that you'll use for all your events. Events would be a logical category!
- Add a title for the test post, add some content. Make sure the Event category is checked.
- Then go to the Event Editor at the bottom of the screen. Use that to add the date and time of the event.
- Publish the post.
**Set Events Calendar Options**
- Now that you have a category for your events and a test post, go to the [Options ➔ Events Calendar](#) screen and set options.
- **Events Category:** Select the category you’re using for your posts.
- **Show Schedule Within Posts:** Includes the date and time in a red box in the post (or not!)
- **Show Events as Blog Entries:** Lets you choose to have your events posts show up on the main page (or not) when the post is published. All events will show up in the Events category page regardless.
  - You may want to write another post near the time of an event to remind people that it’s coming up.
  - Or you can change the date that a post is published, set it for a few days before the event as a reminder. Click on the [Post Timestamp](#) option to do this.
- Don’t forget to click on [Update Options](#)

**Set up Sidebar Widgets**
There are two sidebar widgets to choose from. A calendar with the days of events highlighted. Or a listing of upcoming events.
- Go to [Presentation ➔ Widgets](#)
- Drag the [Event Calendar](#) widget to the sidebar for a calendar display.
- Drag the [Upcoming Events](#) calendar to the sidebar for a list of events.
- Don’t forget to click on [Save Changes](#)

**Doing More With Your Blog**

**BLOGGING TIPS**
- Make it clear what the purpose of your blog is. Put it in the About section of your blog.
- If the information you’re referring to is online, link to it.
- Write like you’re telling a story. Be casual and interesting.
- Include photos and graphics.
- Make sure you add Categories to each posting and show the Categories on the sidebar. This helps your readers find older posts of interest to them.
- Backup your blog content now and then!
- Make it clear how readers can subscribe to your blog.
- If a post is very long, use the “read more” feature to create a break point. This keeps the main page shorter, users will be able to scan your content more easily.

**PUBLICIZE YOUR BLOG (AND WEB SITE)**
- List your blog in library directories and search engines:
  - List of blogging libraries by type of blog:
  - List of blogging libraries by type of library:
    [http://www.blogwithoutalibrary.net/links/](http://www.blogwithoutalibrary.net/links/)
o List of blogs by individual librarians: http://liswiki.org/wiki/Weblogs
o LibWorm – Search library related blogs, podcasts and other RSS feeds.
Browse by some major topic areas as well. http://www.libworm.com/
• Publicize in all the usual places in your library: newsletters, bookmarks, links from your web site, etc.
• Does your town have a web site? Get linked from their site.
• What organizations do you collaborate with? Get linked from their sites too.
• Are you in Wikipedia? You should be! Write an entry about your library, link to your web site and blog. Add information about the library to your town’s Wikipedia entry. It will help you get found in the search engines.

CREATE SOME “LINK LOVE”
• Participate in the ‘blogosphere’. Read other blogs and when you leave comments, make sure your name is linked back to your blog.
• If you cite other people’s blog posts in your posts, use their “trackback” link to refer back to their posts. This will sometimes leave a short link to your post on the other blog.

CREATE AN AUDIENCE
• Ask questions of your audience. Not essay questions, but something they can respond to.
• Respond to readers’ comments and requests.
• Respond in a timely manner.
• Write often! Share the writing job with others. Keep the content fresh.
• Publicize your blog.
• Link to other blogs as appropriate.